Home » wordpress

Tag: wordpress

PeepSo <= 1.6.0 Logged in user privilege escalation

During my recent search for a membership/community plugin I discovered PeepSo, which looks promising for a relatively new product. The WordPress.org plugin page claims there are 800+ users, so this isn’t going to affect too many users.

During initial analysis, I discovered a vulnerability that allows a logged in user to upgrade their account to be an administrator. If you are using PeepSo <= 1.6.0, upgrade immediately.

The developers were quick to respond and deal with this issue, the updated version restricts the meta keys that can be updated.

PeepSo AJAX Actions

PeepSo has implemented their own AJAX handler that is handled differently than the typical WordPress AJAX handler. Their handler allows any function that is a derivative of the PeepSoAjaxCallback class to be called by any user and it is up to the individual functions to provide any form of security. This isn’t necessarily a bad setup, but it does require developers to be extra careful when adding additional functionality.

Unfiltered User Input

A logged in user can call the PeepSoProfilePreferencesAjax->save() function and save meta data for their own account. The function does keep users from modifying an account other than their own. Simply by passing the ‘wp_capabilities’ meta key, a user can escalate their account to be an administrator.

peepso-usersave1

 

Timeline

  • 6/22/2016 3:10pm Contact information requested
  • 6/22/2016 7:10pm Response received from developer
  • 6/22/2016 7:19pm Disclosure email sent
  • 6/23/2016 2:31am Received copy of updated version of code
  • 6/29/2016 Version 1.6.1 released on WordPress.org

MemberSonic Lite <= 1.2 allows login without proper authorization

While looking for a membership plugin for WordPress I stumbled on MemberSonic and the free version of their plugin MemberSonic Lite. After a 10 minute wait while watching their promotional video they finally email you a link to the Lite version. I could not find any indication on the site regarding how many sites/users their plugins have. It appears that they released something back in September of 2012, so there must be more than a handful of users out there.

Anyone using MemberSonic Lite should upgrade immediately, version 1.2 has a flaw allowing an unauthorized user to login to any account simply by knowing the email address associated with the account, this includes any accounts with administrator privileges.

I do not know if this affects the commercial version of the product and I have not done any further auditing of the Lite product. As of 6/28/2016, there has not been a new posting on their blog related to this issue or announcing an update to the Pro version.

Timeline

  • 6/20/2016 12:51pm Initial email attempt
  • 6/22/2016 7:45am Additional email attempt
  • 6/23/2016 2:49pm Final email attempt
  • 6/23/2016 3:07pm Email response received
  • 6/23/2016 3:16pm Full disclosure email sent
  • 6/24/2016 9:53am Received updated version 1.301
  • 6/24/2016 1:19pm Received updated version 1.302 that resolves original issue

Ninja Forms <= 2.9.42 Multiple Critical Security Vulnerabilities

ninjaforms

Multiple critical security vulnerabilities were discovered in the Ninja Forms plugin for WordPress. If you are using a version less than 2.9.42, update immediately!

Ninja Forms is a very popular WordPress plugin to easily build forms for WordPress.  The WordPress.org repository claims there are 500,000+ active installs and ninjaforms.com claims there have been over 2.38 million downloads of the plugin as of May 4th 2016. The plugin is currently listed as the 35th most popular plugin in the WordPress.org repository.

Multiple critical security vulnerabilities were discovered while doing a cursory investigation before deciding to use a plugin and disclosed to the WP Ninjas team. I did not do a full audit of the code base but I recommended the team do a complete audit before releasing an update. After they were patched, I recommended they contact the WordPress.org plugin security team to get help with forcing an automatic security update.

Vulnerable Versions

Version 2.9.36 to 2.9.42 are vulnerable to all of the following critical security vulnerabilities. The most sever vulnerability allows unrestricted uploading of files which could allow remote code execution on a typical webserver setup. The only condition required on a site to attack it is to already have a form enabled, which if this plugin is installed the chances of a form being in use are very high.

Read more